After some tinkering last week, I've decided that it's impractical for me to move forward without renaming some functions. Even with the existing comments, it's extraordinarily difficult to code while having to remember that I need
inventory_item62a instead of
inventory_item63a. I'll be spending some time going through the scripts and renaming these functions.
However, while I'm on the topic of updating code. I really think we should transition the existing "DisplayMessage()" calls to at least include a comment explaining what the message is. I'm hesitant to use the "character.say()" call, it doesn't always look great. "Display()" would probably be a better option; otherwise, let's just add some comments.
While we're on the topic of comments, anyone who wants to add functionality comments to anything in the code will be my personal hero.
I've started compiling these development requirements. I'll place them in a changes spreadsheet... a
delta matrix if you will
(No offense intended delta, just couldn't resist the pun)